use strict;
my $str = 'abc:cde,qwe:rty,tyu:asd
abc,cde,qwe:rty.tyu:asd
abcc|dexqwe-rty!tyu(asd
host1:1,23,dsaf,host2:345
host1:1,23,,host2:345,,
host1:1,23,,host2:345
host1:123,host2:345
eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092
10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092
([^\\\\:\\\\n]+:\\\\d+[,]?)+
([^\\:\\n]+:\\d+)+,?';
my $regex = qr/([^\:\n,]+:\d+,?)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}