re = /([^\:\n,]+:\d+,?)+/m
str = 'abc:cde,qwe:rty,tyu:asd
abc,cde,qwe:rty.tyu:asd
abcc|dexqwe-rty!tyu(asd
host1:1,23,dsaf,host2:345
host1:1,23,,host2:345,,
host1:1,23,,host2:345
host1:123,host2:345
eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092
10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092
([^\\\\:\\\\n]+:\\\\d+[,]?)+
([^\\:\\n]+:\\d+)+,?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end