use strict;
my $str = '[TGF]
TGF
FBC
[TG]';
my $regex = qr`^\[TGF\]`sp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";