const regex = new RegExp('^\\[TGF\\]', 'gs')
const str = `[TGF]
TGF
FBC
[TG]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);