import Foundation
let pattern = #"<IdentityField\b[^>]*path=\"name\"[^>]+?\/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<>
<form onSubmit={handleSubmit(onSave)} className="max-w-3xl" noValidate>
<IdentityField
control={control}
name="Name"
type="text"
path="name"
className="mt-8 mb-16"
/>
<IdentityField
control={control}
name="Projection Link"
type="text"
path="link"
className="mt-8 mb-16"
startAdornment={
<InputAdornment position="start">
https://{subdomain_user}.thebluelobby.com/best-dressed/
</InputAdornment>
}
endAdornment={
<InputAdornment position="end">
<IconButton onClick={openProjectionPage}>
<FuseSvgIcon>heroicons-outline:external-link</FuseSvgIcon>
</IconButton>
</InputAdornment>
}
/>
<IdentityField
control={control}
name="Sexualisation"
type="boolean"
className="mt-8 mb-16"
path="sexualisation"
/>
<IdentityField
control={control}
name="Active"
type="boolean"
className="mt-8 mb-16"
path="active"
/>
<LoadingButton variant="contained" type="submit" disabled={!isEdited}>
Save
</LoadingButton>
</form>
<p>abc</p>
</>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)