use strict;
my $str = '<>
<form onSubmit={handleSubmit(onSave)} className="max-w-3xl" noValidate>
<IdentityField
control={control}
name="Name"
type="text"
path="name"
className="mt-8 mb-16"
/>
<IdentityField
control={control}
name="Projection Link"
type="text"
path="link"
className="mt-8 mb-16"
startAdornment={
<InputAdornment position="start">
https://{subdomain_user}.thebluelobby.com/best-dressed/
</InputAdornment>
}
endAdornment={
<InputAdornment position="end">
<IconButton onClick={openProjectionPage}>
<FuseSvgIcon>heroicons-outline:external-link</FuseSvgIcon>
</IconButton>
</InputAdornment>
}
/>
<IdentityField
control={control}
name="Sexualisation"
type="boolean"
className="mt-8 mb-16"
path="sexualisation"
/>
<IdentityField
control={control}
name="Active"
type="boolean"
className="mt-8 mb-16"
path="active"
/>
<LoadingButton variant="contained" type="submit" disabled={!isEdited}>
Save
</LoadingButton>
</form>
<p>abc</p>
</>';
my $regex = qr/<IdentityField\b[^>]*path=\"name\"[^>]+?\/>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}