const regex = /<IdentityField\b[^>]*path=\"name\"[^>]+?\/>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<IdentityField\\b[^>]*path=\\"name\\"[^>]+?\\\/>', 'gm')
const str = `<>
<form onSubmit={handleSubmit(onSave)} className="max-w-3xl" noValidate>
<IdentityField
control={control}
name="Name"
type="text"
path="name"
className="mt-8 mb-16"
/>
<IdentityField
control={control}
name="Projection Link"
type="text"
path="link"
className="mt-8 mb-16"
startAdornment={
<InputAdornment position="start">
https://{subdomain_user}.thebluelobby.com/best-dressed/
</InputAdornment>
}
endAdornment={
<InputAdornment position="end">
<IconButton onClick={openProjectionPage}>
<FuseSvgIcon>heroicons-outline:external-link</FuseSvgIcon>
</IconButton>
</InputAdornment>
}
/>
<IdentityField
control={control}
name="Sexualisation"
type="boolean"
className="mt-8 mb-16"
path="sexualisation"
/>
<IdentityField
control={control}
name="Active"
type="boolean"
className="mt-8 mb-16"
path="active"
/>
<LoadingButton variant="contained" type="submit" disabled={!isEdited}>
Save
</LoadingButton>
</form>
<p>abc</p>
</>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}