package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<IdentityField\b[^>]*path=\"name\"[^>]+?\/>`)
var str = `<>
<form onSubmit={handleSubmit(onSave)} className="max-w-3xl" noValidate>
<IdentityField
control={control}
name="Name"
type="text"
path="name"
className="mt-8 mb-16"
/>
<IdentityField
control={control}
name="Projection Link"
type="text"
path="link"
className="mt-8 mb-16"
startAdornment={
<InputAdornment position="start">
https://{subdomain_user}.thebluelobby.com/best-dressed/
</InputAdornment>
}
endAdornment={
<InputAdornment position="end">
<IconButton onClick={openProjectionPage}>
<FuseSvgIcon>heroicons-outline:external-link</FuseSvgIcon>
</IconButton>
</InputAdornment>
}
/>
<IdentityField
control={control}
name="Sexualisation"
type="boolean"
className="mt-8 mb-16"
path="sexualisation"
/>
<IdentityField
control={control}
name="Active"
type="boolean"
className="mt-8 mb-16"
path="active"
/>
<LoadingButton variant="contained" type="submit" disabled={!isEdited}>
Save
</LoadingButton>
</form>
<p>abc</p>
</>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}