# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<IdentityField\b[^>]*path=\"name\"[^>]+?\/>"
test_str = ("<>\n"
" <form onSubmit={handleSubmit(onSave)} className=\"max-w-3xl\" noValidate>\n"
" <IdentityField\n"
" control={control}\n"
" name=\"Name\"\n"
" type=\"text\"\n"
" path=\"name\"\n"
" className=\"mt-8 mb-16\"\n"
" />\n\n"
" <IdentityField\n"
" control={control}\n"
" name=\"Projection Link\"\n"
" type=\"text\"\n"
" path=\"link\"\n"
" className=\"mt-8 mb-16\"\n"
" startAdornment={\n"
" <InputAdornment position=\"start\">\n"
" https://{subdomain_user}.thebluelobby.com/best-dressed/\n"
" </InputAdornment>\n"
" }\n"
" endAdornment={\n"
" <InputAdornment position=\"end\">\n"
" <IconButton onClick={openProjectionPage}>\n"
" <FuseSvgIcon>heroicons-outline:external-link</FuseSvgIcon>\n"
" </IconButton>\n"
" </InputAdornment>\n"
" }\n"
" />\n"
" <IdentityField\n"
" control={control}\n"
" name=\"Sexualisation\"\n"
" type=\"boolean\"\n"
" className=\"mt-8 mb-16\"\n"
" path=\"sexualisation\"\n"
" />\n"
" <IdentityField\n"
" control={control}\n"
" name=\"Active\"\n"
" type=\"boolean\"\n"
" className=\"mt-8 mb-16\"\n"
" path=\"active\"\n"
" />\n"
" <LoadingButton variant=\"contained\" type=\"submit\" disabled={!isEdited}>\n"
" Save\n"
" </LoadingButton>\n"
" </form>\n"
"<p>abc</p>\n"
" </>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.