import Foundation
let pattern = #"([bcdfghjklmnpqrstvwxyz]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"extracto de cafe molido a la piedra"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1ilo"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)