use strict;
my $str = 'extracto de cafe molido a la piedra';
my $regex = qr/([bcdfghjklmnpqrstvwxyz]+)/mp;
my $subst = '$1ilo';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";