$re = '/([bcdfghjklmnpqrstvwxyz]+)/m';
$str = 'extracto de cafe molido a la piedra';
$subst = "$1ilo";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;