re = /([bcdfghjklmnpqrstvwxyz]+)/m
str = 'extracto de cafe molido a la piedra'
subst = '$1ilo'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result