re = /\/pojisteni\/pojisteni-vozidel\/([a-z]*-?)pojistovna.*/
str = '/pojisteni/pojisteni-vozidel/cpp-pojistovna'
# Print the match result
str.match(re) do |match|
puts match.to_s
end