$re = '/\/pojisteni\/pojisteni-vozidel\/([a-z]*-?)pojistovna.*/';
$str = '/pojisteni/pojisteni-vozidel/cpp-pojistovna';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);