import Foundation
let pattern = #"[a-z0-9._%+-]+@[a-z0-9.-]+\.[a-z]{2,4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Allowed
one@a.com
one.two@ab.com
one.two@abc.ab
one.two@abc.abc
one.two@abc.abcd
a1_b2@abc.abc
a1b2@ab-cd.abc
a1b2@abcd.ab.cd
// Not allowed
one.two@abc.a
one.two@abc.abcde
one.two@abc.12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)