re = /[a-z0-9._%+-]+@[a-z0-9.-]+\.[a-z]{2,4}$/m
str = '// Allowed
one@a.com
one.two@ab.com
one.two@abc.ab
one.two@abc.abc
one.two@abc.abcd
a1_b2@abc.abc
a1b2@ab-cd.abc
a1b2@abcd.ab.cd
// Not allowed
one.two@abc.a
one.two@abc.abcde
one.two@abc.12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end