using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9._%+-]+@[a-z0-9.-]+\.[a-z]{2,4}$";
string input = @"// Allowed
one@a.com
one.two@ab.com
one.two@abc.ab
one.two@abc.abc
one.two@abc.abcd
a1_b2@abc.abc
a1b2@ab-cd.abc
a1b2@abcd.ab.cd
// Not allowed
one.two@abc.a
one.two@abc.abcde
one.two@abc.12
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}