# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z0-9._%+-]+@[a-z0-9.-]+\.[a-z]{2,4}$"
test_str = ("// Allowed\n"
"one@a.com\n"
"one.two@ab.com\n"
"one.two@abc.ab\n"
"one.two@abc.abc\n"
"one.two@abc.abcd\n"
"a1_b2@abc.abc\n"
"a1b2@ab-cd.abc\n"
"a1b2@abcd.ab.cd\n\n"
"// Not allowed \n"
"one.two@abc.a\n"
"one.two@abc.abcde\n"
"one.two@abc.12\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.