import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9._%+-]+@[a-z0-9.-]+\\.[a-z]{2,4}$";
final String string = "// Allowed\n"
+ "one@a.com\n"
+ "one.two@ab.com\n"
+ "one.two@abc.ab\n"
+ "one.two@abc.abc\n"
+ "one.two@abc.abcd\n"
+ "a1_b2@abc.abc\n"
+ "a1b2@ab-cd.abc\n"
+ "a1b2@abcd.ab.cd\n\n"
+ "// Not allowed \n"
+ "one.two@abc.a\n"
+ "one.two@abc.abcde\n"
+ "one.two@abc.12\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}