re = /^\/(?:[^\W_]+(?:\*|\/\*)?|\*)?$/m
str = '/mayapp/*
/
/mayapp
/wewewe*
/mayapp/
/mayapp/*foo
/ma222pp/foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end