#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/(?:[^\W_]+(?:\*|\/\*)?|\*)?$"
Local $sString = "/mayapp/*" & @CRLF & _
"/" & @CRLF & _
"/mayapp" & @CRLF & _
"/wewewe*" & @CRLF & _
"/mayapp/" & @CRLF & _
"/mayapp/*foo" & @CRLF & _
"/ma222pp/foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")