$re = '/^\/(?:[^\W_]+(?:\*|\/\*)?|\*)?$/m';
$str = '/mayapp/*
/
/mayapp
/wewewe*
/mayapp/
/mayapp/*foo
/ma222pp/foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);