package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(?:[^\W_]+(?:\*|\/\*)?|\*)?$`)
var str = `/mayapp/*
/
/mayapp
/wewewe*
/mayapp/
/mayapp/*foo
/ma222pp/foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}