using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?:[^\W_]+(?:\*|\/\*)?|\*)?$";
string input = @"/mayapp/*
/
/mayapp
/wewewe*
/mayapp/
/mayapp/*foo
/ma222pp/foo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}