$re = '/((((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?)([,](((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?))*) ((((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?)([,](((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?))*) ((((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?)([,](((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?))*) ((((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)([,](((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?))*) ((((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)([,](((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?))*)/m';
$str = '*/5 2/3,22 * JAN,FEB 1-5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);