using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?)([,](((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?))*) ((((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?)([,](((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?))*) ((((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?)([,](((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?))*) ((((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)([,](((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?))*) ((((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)([,](((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?))*)";
string input = @"*/5 2/3,22 * JAN,FEB 1-5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}