#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?)([,](((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?))*) ((((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?)([,](((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?))*) ((((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?)([,](((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?))*) ((((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)([,](((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?))*) ((((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)([,](((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?))*)"
Local $sString = "*/5 2/3,22 * JAN,FEB 1-5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")