import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?)([,](((([1-5]?[0-9])([-]([1-5]?[0-9]))?)|[*])([/]([1-5]?[0-9]))?))*) ((((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?)([,](((([2][0-3]|[1]?[0-9])([-]([2][0-3]|[1]?[0-9]))?)|[*])([/]([2][0-3]|[1]?[0-9]))?))*) ((((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?)([,](((([3][0-1]|[1-2]?[0-9])([-]([3][0-1]|[1-2]?[0-9]))?)|[*])([/]([3][0-1]|[1-2]?[0-9]))?))*) ((((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)([,](((([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)([-]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)|[*])([/]([1][0-2]|[0-9]|JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?))*) ((((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)([,](((([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT)([-]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?)|[*])([/]([0-7]|SUN|MON|TUE|WED|THU|FRI|SAT))?))*)";
final String string = "*/5 2/3,22 * JAN,FEB 1-5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}