re = /[хХ]++ (?>(?!\/\\)[^\p{L}\d]|[хХ]+)*+
[уУ]++ (?>(?!\/\\)[^\p{L}\d]|[уУ]+)*+
[йЙ]++ (?>(?!\/\\)[^\p{L}\d]|[йЙ]+)*+/xi
str = 'хуй хуй хуй'
# Print the match result
str.match(re) do |match|
puts match.to_s
end