using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[хХ]++ (?>(?!\/\\)[^\p{L}\d]|[хХ]+)*+
[уУ]++ (?>(?!\/\\)[^\p{L}\d]|[уУ]+)*+
[йЙ]++ (?>(?!\/\\)[^\p{L}\d]|[йЙ]+)*+";
string input = @"хуй хуй хуй";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace | RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}