#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sXxui)[хХ]++ (?>(?!\/\\)[^\p{L}\d]|[хХ]+)*+" & @CRLF & _
"[уУ]++ (?>(?!\/\\)[^\p{L}\d]|[уУ]+)*+" & @CRLF & _
"[йЙ]++ (?>(?!\/\\)[^\p{L}\d]|[йЙ]+)*+"
Local $sString = "хуй хуй хуй"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")