const regex = /[хХ]++ (?>(?!\/\\)[^\p{L}\d]|[хХ]+)*+
[уУ]++ (?>(?!\/\\)[^\p{L}\d]|[уУ]+)*+
[йЙ]++ (?>(?!\/\\)[^\p{L}\d]|[йЙ]+)*+/sui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[хХ]++ (?>(?!\\\/\\\\)[^\\p{L}\\d]|[хХ]+)*+
[уУ]++ (?>(?!\\\/\\\\)[^\\p{L}\\d]|[уУ]+)*+
[йЙ]++ (?>(?!\\\/\\\\)[^\\p{L}\\d]|[йЙ]+)*+', 'sui')
const str = `хуй хуй хуй`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}