import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[хХ]++ (?>(?!\\/\\\\)[^\\p{L}\\d]|[хХ]+)*+\n"
+ "[уУ]++ (?>(?!\\/\\\\)[^\\p{L}\\d]|[уУ]+)*+\n"
+ "[йЙ]++ (?>(?!\\/\\\\)[^\\p{L}\\d]|[йЙ]+)*+";
final String string = "хуй хуй хуй";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS | Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}