import Foundation
let pattern = #"^[A-Z]+(?:_{0,2}[A-Z]+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a_raga
_raga
RAGGA DAFDASDA
RAGGA_DAFDASDA
RAGGA-DAFDASDARAGGA
RAGGA%DAFDASDA
RAGGA?DAFDASDA
RAGGA_DAFDASDA_A
RAGGA_DAFDASDA_Aa
aaaaaa_RAGGA_DAFDASDA_A
RAGGA_DAFDASDA
RAGGA__DAFDASDA
sadd
AAA_B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)