$re = '/^[A-Z]+(?:_{0,2}[A-Z]+)*$/m';
$str = 'a_raga
_raga
RAGGA DAFDASDA
RAGGA_DAFDASDA
RAGGA-DAFDASDARAGGA
RAGGA%DAFDASDA
RAGGA?DAFDASDA
RAGGA_DAFDASDA_A
RAGGA_DAFDASDA_Aa
aaaaaa_RAGGA_DAFDASDA_A
RAGGA_DAFDASDA
RAGGA__DAFDASDA
sadd
AAA_B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);