using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+(?:_{0,2}[A-Z]+)*$";
string input = @"a_raga
_raga
RAGGA DAFDASDA
RAGGA_DAFDASDA
RAGGA-DAFDASDARAGGA
RAGGA%DAFDASDA
RAGGA?DAFDASDA
RAGGA_DAFDASDA_A
RAGGA_DAFDASDA_Aa
aaaaaa_RAGGA_DAFDASDA_A
RAGGA_DAFDASDA
RAGGA__DAFDASDA
sadd
AAA_B
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}