#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+(?:_{0,2}[A-Z]+)*$"
Local $sString = "a_raga" & @CRLF & _
"_raga" & @CRLF & _
"RAGGA DAFDASDA" & @CRLF & _
"RAGGA_DAFDASDA" & @CRLF & _
"RAGGA-DAFDASDARAGGA" & @CRLF & _
"RAGGA%DAFDASDA" & @CRLF & _
"RAGGA?DAFDASDA" & @CRLF & _
"RAGGA_DAFDASDA_A" & @CRLF & _
"RAGGA_DAFDASDA_Aa" & @CRLF & _
"aaaaaa_RAGGA_DAFDASDA_A" & @CRLF & _
"RAGGA_DAFDASDA" & @CRLF & _
"RAGGA__DAFDASDA" & @CRLF & _
"sadd" & @CRLF & _
"AAA_B" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")