package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+(?:_{0,2}[A-Z]+)*$`)
var str = `a_raga
_raga
RAGGA DAFDASDA
RAGGA_DAFDASDA
RAGGA-DAFDASDARAGGA
RAGGA%DAFDASDA
RAGGA?DAFDASDA
RAGGA_DAFDASDA_A
RAGGA_DAFDASDA_Aa
aaaaaa_RAGGA_DAFDASDA_A
RAGGA_DAFDASDA
RAGGA__DAFDASDA
sadd
AAA_B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}