// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((?:\+|00)964)|(0)*)7\d{9}$").unwrap();
let string = "7701234567
770123456
77012345678
07701234567
0770123456
077012345678
+9647701234567
+964770123456
+96477012345678
009647701234567
00964770123456
0096477012345678
738479299372492
0770 123 4567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}