package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((?:\+|00)964)|(0)*)7\d{9}$`)
var str = `7701234567
770123456
77012345678
07701234567
0770123456
077012345678
+9647701234567
+964770123456
+96477012345678
009647701234567
00964770123456
0096477012345678
738479299372492
0770 123 4567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}