using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((?:\+|00)964)|(0)*)7\d{9}$";
string input = @"7701234567
770123456
77012345678
07701234567
0770123456
077012345678
+9647701234567
+964770123456
+96477012345678
009647701234567
00964770123456
0096477012345678
738479299372492
0770 123 4567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}