re = /^(((?:\+|00)964)|(0)*)7\d{9}$/m
str = '7701234567
770123456
77012345678
07701234567
0770123456
077012345678
+9647701234567
+964770123456
+96477012345678
009647701234567
00964770123456
0096477012345678
738479299372492
0770 123 4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end