use strict;
my $str = '7701234567
770123456
77012345678
07701234567
0770123456
077012345678
+9647701234567
+964770123456
+96477012345678
009647701234567
00964770123456
0096477012345678
738479299372492
0770 123 4567';
my $regex = qr/^(((?:\+|00)964)|(0)*)7\d{9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}