# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Skelettalter|Knochenalter)\s+nach\s+Greulich\s+&\s+Pyle.*?((\d+,\d+)\s*Jahre|(\d+\.\d+)\s*Jahre|(\d+)\s*Jahre\s+und\s+(\d+)\s*Monate|(\d+)?\/?\s*(?:(\d+)(?:o)?\/12)?\s*Jahre|(\d+)\s*Monate)"
test_str = ("Skelettalter nach Greulich & Pyle : 7,74 Jahre\n"
"Skelettalter nach Greulich & Pyle : 5.12 Jahre\n"
"Skelettalter nach Greulich & Pyle : 4/9/12 Jahre mit leichter Dissoziation\n"
"Skelettalter nach Greulich & Pyle. 4 9/12 Jahre\n"
"Skelettalter nach Greulich & Pyle : 6/12 Jahre\n"
"Skelettalter nach Greulich & Pyle : 13 6o/12 Jahre\n"
"Skelettalter nach Greulich & Pyle : 14Jahre\n"
"Skelettalter nach Greulich & Pyle : weiterhin 13 3/12 Jahre\n"
"Skelettalter nach Greulich & Pyle : 15/15/15 15 Jahre\n"
"Das Skelettalter nach Greulich & Pyle entspricht dem eines Erwachsenen.\n"
"Skelettalter nach Greulich & Pyle weiterhin: 3 3/12 mit Dissoziation\n"
"Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 Jahre)\n"
"Skelettalter nach Greulich & Pyle : 13 3/12 unter Annahme eines weiblichen Standards 14 6/12 Jahre unter Annahme eines männlichen Standards\n"
"Skelettalter nach Greulich & Pyle: vollständig ausgereift\n"
"Chronologisches Alter 17 8/12 Jahre, Skelettalter nach Greulich & Pyle 13 Jahre.\n"
"Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 0/12 Jahre)\n"
"Skelettalter nach Greulich & Pyle : 3 Monate\n"
"Knochenalter nach Greulich & Pyle : 18 Jahre und 6 Monate\n"
"Chronologisches Alter 5 Tage, Skelettalter nach Greulich & Pyle einem Neugeborenen entsprechend.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.