#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Skelettalter|Knochenalter)\s+nach\s+Greulich\s+&\s+Pyle.*?((\d+,\d+)\s*Jahre|(\d+\.\d+)\s*Jahre|(\d+)\s*Jahre\s+und\s+(\d+)\s*Monate|(\d+)?\/?\s*(?:(\d+)(?:o)?\/12)?\s*Jahre|(\d+)\s*Monate)"
Local $sString = "Skelettalter nach Greulich & Pyle : 7,74 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 5.12 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 4/9/12 Jahre mit leichter Dissoziation" & @CRLF & _
"Skelettalter nach Greulich & Pyle. 4 9/12 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 6/12 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 13 6o/12 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 14Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : weiterhin 13 3/12 Jahre" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 15/15/15 15 Jahre" & @CRLF & _
"Das Skelettalter nach Greulich & Pyle entspricht dem eines Erwachsenen." & @CRLF & _
"Skelettalter nach Greulich & Pyle weiterhin: 3 3/12 mit Dissoziation" & @CRLF & _
"Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 Jahre)" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 13 3/12 unter Annahme eines weiblichen Standards 14 6/12 Jahre unter Annahme eines männlichen Standards" & @CRLF & _
"Skelettalter nach Greulich & Pyle: vollständig ausgereift" & @CRLF & _
"Chronologisches Alter 17 8/12 Jahre, Skelettalter nach Greulich & Pyle 13 Jahre." & @CRLF & _
"Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 0/12 Jahre)" & @CRLF & _
"Skelettalter nach Greulich & Pyle : 3 Monate" & @CRLF & _
"Knochenalter nach Greulich & Pyle : 18 Jahre und 6 Monate" & @CRLF & _
"Chronologisches Alter 5 Tage, Skelettalter nach Greulich & Pyle einem Neugeborenen entsprechend."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")