$re = '/(Skelettalter|Knochenalter)\s+nach\s+Greulich\s+&\s+Pyle.*?((\d+,\d+)\s*Jahre|(\d+\.\d+)\s*Jahre|(\d+)\s*Jahre\s+und\s+(\d+)\s*Monate|(\d+)?\/?\s*(?:(\d+)(?:o)?\/12)?\s*Jahre|(\d+)\s*Monate)/m';
$str = 'Skelettalter nach Greulich & Pyle : 7,74 Jahre
Skelettalter nach Greulich & Pyle : 5.12 Jahre
Skelettalter nach Greulich & Pyle : 4/9/12 Jahre mit leichter Dissoziation
Skelettalter nach Greulich & Pyle. 4 9/12 Jahre
Skelettalter nach Greulich & Pyle : 6/12 Jahre
Skelettalter nach Greulich & Pyle : 13 6o/12 Jahre
Skelettalter nach Greulich & Pyle : 14Jahre
Skelettalter nach Greulich & Pyle : weiterhin 13 3/12 Jahre
Skelettalter nach Greulich & Pyle : 15/15/15 15 Jahre
Das Skelettalter nach Greulich & Pyle entspricht dem eines Erwachsenen.
Skelettalter nach Greulich & Pyle weiterhin: 3 3/12 mit Dissoziation
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 Jahre)
Skelettalter nach Greulich & Pyle : 13 3/12 unter Annahme eines weiblichen Standards 14 6/12 Jahre unter Annahme eines männlichen Standards
Skelettalter nach Greulich & Pyle: vollständig ausgereift
Chronologisches Alter 17 8/12 Jahre, Skelettalter nach Greulich & Pyle 13 Jahre.
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 0/12 Jahre)
Skelettalter nach Greulich & Pyle : 3 Monate
Knochenalter nach Greulich & Pyle : 18 Jahre und 6 Monate
Chronologisches Alter 5 Tage, Skelettalter nach Greulich & Pyle einem Neugeborenen entsprechend.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);