const regex = /(Skelettalter|Knochenalter)\s+nach\s+Greulich\s+&\s+Pyle.*?((\d+,\d+)\s*Jahre|(\d+\.\d+)\s*Jahre|(\d+)\s*Jahre\s+und\s+(\d+)\s*Monate|(\d+)?\/?\s*(?:(\d+)(?:o)?\/12)?\s*Jahre|(\d+)\s*Monate)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Skelettalter|Knochenalter)\\s+nach\\s+Greulich\\s+&\\s+Pyle.*?((\\d+,\\d+)\\s*Jahre|(\\d+\\.\\d+)\\s*Jahre|(\\d+)\\s*Jahre\\s+und\\s+(\\d+)\\s*Monate|(\\d+)?\\\/?\\s*(?:(\\d+)(?:o)?\\\/12)?\\s*Jahre|(\\d+)\\s*Monate)', 'gm')
const str = `Skelettalter nach Greulich & Pyle : 7,74 Jahre
Skelettalter nach Greulich & Pyle : 5.12 Jahre
Skelettalter nach Greulich & Pyle : 4/9/12 Jahre mit leichter Dissoziation
Skelettalter nach Greulich & Pyle. 4 9/12 Jahre
Skelettalter nach Greulich & Pyle : 6/12 Jahre
Skelettalter nach Greulich & Pyle : 13 6o/12 Jahre
Skelettalter nach Greulich & Pyle : 14Jahre
Skelettalter nach Greulich & Pyle : weiterhin 13 3/12 Jahre
Skelettalter nach Greulich & Pyle : 15/15/15 15 Jahre
Das Skelettalter nach Greulich & Pyle entspricht dem eines Erwachsenen.
Skelettalter nach Greulich & Pyle weiterhin: 3 3/12 mit Dissoziation
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 Jahre)
Skelettalter nach Greulich & Pyle : 13 3/12 unter Annahme eines weiblichen Standards 14 6/12 Jahre unter Annahme eines männlichen Standards
Skelettalter nach Greulich & Pyle: vollständig ausgereift
Chronologisches Alter 17 8/12 Jahre, Skelettalter nach Greulich & Pyle 13 Jahre.
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 0/12 Jahre)
Skelettalter nach Greulich & Pyle : 3 Monate
Knochenalter nach Greulich & Pyle : 18 Jahre und 6 Monate
Chronologisches Alter 5 Tage, Skelettalter nach Greulich & Pyle einem Neugeborenen entsprechend.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}