use strict;
my $str = 'Skelettalter nach Greulich & Pyle : 7,74 Jahre
Skelettalter nach Greulich & Pyle : 5.12 Jahre
Skelettalter nach Greulich & Pyle : 4/9/12 Jahre mit leichter Dissoziation
Skelettalter nach Greulich & Pyle. 4 9/12 Jahre
Skelettalter nach Greulich & Pyle : 6/12 Jahre
Skelettalter nach Greulich & Pyle : 13 6o/12 Jahre
Skelettalter nach Greulich & Pyle : 14Jahre
Skelettalter nach Greulich & Pyle : weiterhin 13 3/12 Jahre
Skelettalter nach Greulich & Pyle : 15/15/15 15 Jahre
Das Skelettalter nach Greulich & Pyle entspricht dem eines Erwachsenen.
Skelettalter nach Greulich & Pyle weiterhin: 3 3/12 mit Dissoziation
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 Jahre)
Skelettalter nach Greulich & Pyle : 13 3/12 unter Annahme eines weiblichen Standards 14 6/12 Jahre unter Annahme eines männlichen Standards
Skelettalter nach Greulich & Pyle: vollständig ausgereift
Chronologisches Alter 17 8/12 Jahre, Skelettalter nach Greulich & Pyle 13 Jahre.
Skelettalter nach Greulich & Pyle : vollständig ausgereift (18 0/12 Jahre)
Skelettalter nach Greulich & Pyle : 3 Monate
Knochenalter nach Greulich & Pyle : 18 Jahre und 6 Monate
Chronologisches Alter 5 Tage, Skelettalter nach Greulich & Pyle einem Neugeborenen entsprechend.';
my $regex = qr/(Skelettalter|Knochenalter)\s+nach\s+Greulich\s+&\s+Pyle.*?((\d+,\d+)\s*Jahre|(\d+\.\d+)\s*Jahre|(\d+)\s*Jahre\s+und\s+(\d+)\s*Monate|(\d+)?\/?\s*(?:(\d+)(?:o)?\/12)?\s*Jahre|(\d+)\s*Monate)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}