import Foundation
let pattern = #"^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bhargavi.bommidi@gmail.com
lovely.bhar@rasna
rasna_bha@phb.in
^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)